BWA

BWA is a software package for mapping low-divergent sequences against a large reference genome, such as the human genome. It consists of three algorithms: BWA-backtrack, BWA-SW and BWA-MEM.

Availability and Restrictions

Versions

The following versions of BWA are available on OSC clusters:

Version owens PITZER
0.7.13  X*  
0.7.17 X X*
0.7.17-r1198 X X
* Current default version

You can use module spider bwa to view available modules for a given machine. Feel free to contact OSC Help if you need other versions for your work.

0.7.17-r1198 is the latest version at the time of the installation on July 2019.

Due to a recent software vulnerability discovered in bwa versions 0.7.17 and 0.7.13, it is highly recommended to immediately stop using these versions and instead use bwa/0.7.17-r1198. For more information, see herehttps://www.osc.edu/resources/technical_support/known_issues/bwa_software_security_vulnerability

Access

BWA is available to all OSC users without restriction.

Publisher/Vendor/Repository and License Type

Li H. and Durbin R., Open source

Usage

Usage on Owens

Set-up

To configure your environment for use of BWA, run the following command: module load bwa. The default version will be loaded. To select a particular BWA version, use module load bwa/version. For example, use module load bwa/0.7.13 to load BWA 0.7.13.

Usage on Pitzer

Set-up

To configure your environment for use of BWA, run the following command: module load bwa. The default version will be loaded.

Further Reading

Supercomputer: 
Service: 
Fields of Science: