BamTools

BamTools provides both a programmer's API and an end-user's toolkit for handling BAM files.

Availability and Restrictions

The following versions of BamTools are available on OSC clusters:

Version Oakley Owens
2.2.2 X X*
2.4.0 X*  
*: Current default version

You can use  module spider bamtools to view available modules for a given machine. Feel free to contact OSC Help if you need other versions for your work.

Access

BamTools is available to all OSC users without restriction.

Usage on Oakley

Set-up

To configure your environment for use of BamTools, run the following command:   module load bamtools . The default version will be loaded. To select a particular BamTools version, use  module load bamtools/version . For example, use  module load bamtools/2.2.2 to load BamTools 2.2.2.

Usage on Owens

Set-up

To configure your environment for use of BamTools, run the following command:   module load bamtools . The default version will be loaded. To select a particular BamTools version, use  module load bamtools/version . For example, use  module load bamtools/2.2.2 to load BamTools 2.2.2.

Further Reading

Service: 
Fields of Science: